Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Sujet : [résolu]le serveur renvoie le mauvais type MIME (fichier WebM)

Bonsoir,

J'ai l'habitude de poster sur mon blogue des séquence audio ou audio-vidéo avec la balise audio ou vidéo de HTML5.

Jusque là je mettais en ligne mes fichiers au format Ogg Vorbis (son) ou Ogg Theora (vidéo).

Avec le lancement de WebM par Google comme format ouvert pour la diffusion audio/vidéo, je convertis mes fichiers au nouveau format. Et là ça ne marche pas.

D'après Matthew Gregan de Mozilla et Lachlan Hunt d'Opera le serveur ne renvoie pas le bon type MIME

Matthew Gregan :

The file is being served with a Content-Type of application/octet-stream which is why Firefox refuses to play it.
If you correct the configuration on your HTTP server to serve the file as audio/webm it should work fine.

Lachlan Hunt :

Your server is sending the wrong MIME type:

$ curl -I http://libre-ouvert.toile-libre.org/dat … hlala.webm
HTTP/1.1 200 OK
Connection: close
Content-Type: application/octet-stream
ETag: "628056108"
Last-Modified: Fri, 09 Apr 2010 00:16:08 GMT
Content-Length: 85960
Date: Sat, 29 May 2010 21:51:52 GMT
Server: Lighttpd
Set-Cookie: SERVERID=prozac; path=/
Cache-control: private

That Content-Type should be audio/webm.

If you were using Apache, then you could fix this by adding these lines
to your .htaccess file:

AddType video/webm .webm
AddType audio/webm .weba

Then change the file extension of your audio-only webm files to .weba so
they are correctly sent as audio/webm.

However, the headers above show that you're using Lighttpd and I believe
you will therefore have to edit lighttpd.conf to assign the appropriate
types.  I'm not familiar with Lighttpd, but this tutorial seems to
indicate how its done.

http://redmine.lighttpd.net/wiki/1/Tuto … figuration

I guess you should just insert these two lines in the the appropriate
location in lighttpd.conf:

mimetype.assign = (
   ...,
   ".webm" => "video/webm",
   ".weba" => "audio/webm",
   ...
)

Le problème peut-il être corrigé ?

Merci d'avance

Dernière modification par antistress (2010-05-30 00:01:42)

Thumbs up Thumbs down


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Re : [résolu]le serveur renvoie le mauvais type MIME (fichier WebM)

dites moi si je dois plutôt envoyer une requête sur http://redmine.lighttpd.net/projects/lighttpd/issues qu'ici ( et si vous pouvez mettre en place le palliatif indiqué en attendant)

merci

Thumbs up Thumbs down

3

Re : [résolu]le serveur renvoie le mauvais type MIME (fichier WebM)

Je vais modifier la configuration sur les serveurs.
Mais effectivement, il faut le rapporter à lighttpd.net

NS

EDIT:

$ curl -I http://libre-ouvert.toile-libre.org/data/documents/retour_vers_le_futur_2_ohlala.webm
HTTP/1.1 200 OK
Connection: close
Content-Type: video/webm
Accept-Ranges: bytes
ETag: "1775140618"
Last-Modified: Sat, 29 May 2010 18:39:34 GMT
Content-Length: 86306
Date: Mon, 07 Jun 2010 21:41:45 GMT
Server: Lighttpd
Set-Cookie: SERVERID=turlute; path=/
Cache-control: private

Fait smile

Thumbs up Thumbs down

Re : [résolu]le serveur renvoie le mauvais type MIME (fichier WebM)

et

$ curl -I http://libre-ouvert.toile-libre.org/data/documents/retour_vers_le_futur_2_ohlala.weba
HTTP/1.1 200 OK
Connection: close
Content-Type: audio/webm
Accept-Ranges: bytes
ETag: "1567424431"
Last-Modified: Mon, 07 Jun 2010 23:17:51 GMT
Content-Length: 86306
Date: Mon, 07 Jun 2010 22:50:29 GMT
Server: Lighttpd
Set-Cookie: SERVERID=turlute; path=/
Cache-control: private

excellent, merci beaucoup  smile

Thumbs up Thumbs down


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Re : [résolu]le serveur renvoie le mauvais type MIME (fichier WebM)

c'est ici http://redmine.lighttpd.net/issues/2224

Thumbs up Thumbs down