Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Sujet : [Résolu] Problème dans l'installation de wordpress

Bonjour,
je n'arrive pas à installer wordpress.
Je pense pourtant avoir configurer wp-config.php comme il faut

// ** Réglages MySQL - Votre hébergeur doit vous fournir ces informations. ** //
/** Nom de la base de données de WordPress. */
define('DB_NAME', ' levoyagedezi_bil');

/** Utilisateur de la base de données MySQL. */
define('DB_USER', ' levoyagedezi_bil');

/** Mot de passe de la base de données MySQL. */
define('DB_PASSWORD', '******');

/** Adresse de l'hébergement MySQL. */
define('DB_HOST', 'sql.toile-libre.org');

/** Jeu de caractères à utiliser par la base de données lors de la création des tables. */
define('DB_CHARSET', 'utf8');

Mais voici ce que me renvoie /wp-admin/install.php :

Erreur lors de l’établissement de la connexion à la base de données

Cela signifie soit que l’identifiant et/ou le mot de passe indiqué(s) dans votre fichier wp-config.php sont incorrects, ou que le serveur de base de données à l’adresse sql.toile-libre.org est inaccessible - cela peut indiquer que le serveur de base de données de votre hébergeur est défaillant.

    Êtes-vous certain(e) d’avoir correctement indiqué votre identifiant et votre mot de passe ?
    Êtes-vous certain(e) d’avoir entré le bon serveur de base de données ?
    Êtes-vous certain(e) que le serveur de base de données fonctionne correctement ?

Si vous n’êtes pas sûr(e) de bien comprendre les mots de cette liste, vous devriez sans doute prendre contact avec votre hébergeur. Si malgré cela cette erreur s’affiche toujours, indiquez votre problème au forum d’entraide en français.

J'ai fouillé les forums et les tuto, et je ne comprends pas d'où vient le problème. Apparemment, je ne suis pas le premier à avoir des soucis avec wp, mais je ne trouve pas ce problème résolu sur les forums.

Il y a peut-etre un truc que je ne comprends pas... faut-il aller faire quelque chose dans mysql.toile-libre.org ?

Merci pour le coup de main
Z.

Dernière modification par zibil (2012-12-21 21:24:18)

Thumbs up Thumbs down


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /data/web/4/0/forum.toile-libre.org/htdocs/include/parser.php on line 738

Re : [Résolu] Problème dans l'installation de wordpress

Essaie avec :

define('DB_HOST', 'http://sql.toile-libre.org.sqlite');

Ca ne me semble pas très logique de mettre sqlite pour une base de données MySql, mais c'est pourtant comme ça que je me connecte à ma db depuis php et ça fonctionne.


Il y a peut-etre un truc que je ne comprends pas... faut-il aller faire quelque chose dans mysql.toile-libre.org ?

Ca je ne sais pas du tout, je n'ai pas installé wordpress. Mais je vois déjà une erreur possible dans le DB_HOST.

Geoforge  - Collection de plateformes logicielles en géosciences
www.geoforge.org

Thumbs up Thumbs down

3

Re : [Résolu] Problème dans l'installation de wordpress

Merci pour la réponse.
J'ai essayé, mais ça me renvoie la même réponse. Le serveur est toujours inaccessible...

Thumbs up Thumbs down

4

Re : [Résolu] Problème dans l'installation de wordpress

Bon, j'ai trouvé !
en fait, dans mon config.php il y avait un espace devant le nom de la base de données et le nom d'utilisateur,
tout ça parce que, fainéant que je suis, j'avais fait des copier-coller au lieu de les retaper, et je ne m'étais pas aperçu qu'un espace était venu avec...
Ou comment perdre trois jours en pensant gagner trois secondes !

Dernière modification par zibil (2012-12-21 21:24:59)

Thumbs up Thumbs down